summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRomain Gonçalves <me@rgoncalves.se>2022-10-03 21:13:02 +0200
committerRomain Gonçalves <me@rgoncalves.se>2022-10-03 21:13:02 +0200
commit447a74aa4150c44d948be9ee9b4e6a7f924d0738 (patch)
tree3bf31077a555891987e5b6e05ad92f1f79347a26 /pyproject.toml
downloadpydanclick-447a74aa4150c44d948be9ee9b4e6a7f924d0738.tar.gz
wip: initHEADtrunk
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..1744abd
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,30 @@
+[tool.poetry]
+name = "pydanclick"
+version = "0.1.0"
+description = "Back and forth serialization with click and pydantic!"
+authors = ["Romain Gonçalves <me@rgoncalves.se>"]
+packages = [
+ { include = "pydanclick" },
+]
+
+
+[tool.poetry.dependencies]
+python = "^3.10"
+pydantic = "^1.9.1"
+typing-extensions = "^4.3.0"
+
+[tool.poetry.dev-dependencies]
+ipython = "^8.4.0"
+flake8 = "^4.0.1"
+black = "^22.6.0"
+isort = "^5.10.1"
+
+[tool.poetry.group.dev.dependencies]
+mypy = "^0.981"
+
+[tool.mypy]
+plugins = "pydantic.mypy"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"
remember that computers suck.