summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e62c337..b36e2c5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -13,6 +13,8 @@ pydantic = "^2.1.1"
httpx = "^0.24.1"
mypy = "^1.4.1"
selectolax = "^0.3.16"
+pytest = "^7.4.0"
+flake8 = "^6.1.0"
[tool.mypy]
plugins = [
@@ -32,6 +34,9 @@ init_forbid_extra = true
init_typed = true
warn_required_dynamic_aliases = true
+[tool.black]
+line-length = 79
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
remember that computers suck.