summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRomain Gonçalves <me@rgoncalves.se>2023-08-20 20:25:31 +0200
committerRomain Gonçalves <me@rgoncalves.se>2023-08-20 20:25:31 +0200
commitc4f52cd8853c18671797ce196f4a7d32afa6d6f5 (patch)
tree3e62f582405d0b1647be3a5762a7505f50ff3a7b /pyproject.toml
downloadcip_paris_client-c4f52cd8853c18671797ce196f4a7d32afa6d6f5.tar.gz
feat: scaffold library
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e62c337
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,37 @@
+[tool.poetry]
+name = "cip-paris-client"
+version = "0.1.0"
+description = "Client for Cinémas Indépendants Parisiens API and movie sessions."
+authors = ["Romain Gonçalves <me@rgoncalves.se>"]
+license = "MIT"
+readme = "README.md"
+packages = [{include = "cip_paris_client"}]
+
+[tool.poetry.dependencies]
+python = "^3.11"
+pydantic = "^2.1.1"
+httpx = "^0.24.1"
+mypy = "^1.4.1"
+selectolax = "^0.3.16"
+
+[tool.mypy]
+plugins = [
+ "pydantic.mypy"
+]
+
+follow_imports = "silent"
+warn_redundant_casts = true
+warn_unused_ignores = true
+disallow_any_generics = true
+check_untyped_defs = true
+no_implicit_reexport = true
+disallow_untyped_defs = true
+
+[tool.pydantic-mypy]
+init_forbid_extra = true
+init_typed = true
+warn_required_dynamic_aliases = true
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
remember that computers suck.